<!DOCTYPE html>



<html lang="en-US" prefix="og: http://ogp.me/ns#">



<head>



<meta charset="UTF-8">



<meta name="viewport" content="width=device-width, initial-scale=1.0">



<title>- Letters, May 7 - Chestnut Hill Local Philadelphia PA -</title>



<link rel="profile" href="https://gmpg.org/xfn/11">



<link rel="pingback" href="https://www.chestnuthilllocal.com/xmlrpc.php">



		<!-- <script src="https://www.paypalobjects.com/api/checkout.js" data-version-4></script> -->
		
<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Unprecedented time caring for our community First, and most importantly, thank you for staying at home to help prevent the spread of COVID-19 in our"/>
<link rel="canonical" href="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/" />
<link rel="publisher" href="https://plus.google.com/+Chestnuthilllocal/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Letters, May 7 - Chestnut Hill Local Philadelphia PA" />
<meta property="og:description" content="Unprecedented time caring for our community First, and most importantly, thank you for staying at home to help prevent the spread of COVID-19 in our" />
<meta property="og:url" content="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/" />
<meta property="og:site_name" content="Chestnut Hill Local Philadelphia PA" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Chestnut-Hill-Local/166212318997" />
<meta property="article:tag" content="Letters" />
<meta property="article:section" content="Letters" />
<meta property="article:published_time" content="2020-05-06T13:35:07+00:00" />
<meta property="article:modified_time" content="2020-05-06T13:35:08+00:00" />
<meta property="og:updated_time" content="2020-05-06T13:35:08+00:00" />
<meta property="og:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2014/01/Letters.jpg" />
<meta property="og:image:secure_url" content="https://www.chestnuthilllocal.com/wp-content/uploads/2014/01/Letters.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Unprecedented time caring for our community First, and most importantly, thank you for staying at home to help prevent the spread of COVID-19 in our" />
<meta name="twitter:title" content="Letters, May 7 - Chestnut Hill Local Philadelphia PA" />
<meta name="twitter:site" content="@TheCHLocal" />
<meta name="twitter:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2014/01/Letters.jpg" />
<meta name="twitter:creator" content="@TheCHLocal" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Feed" href="https://www.chestnuthilllocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Comments Feed" href="https://www.chestnuthilllocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Letters, May 7 Comments Feed" href="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.chestnuthilllocal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//www.chestnuthilllocal.com/wp-content/plugins/all-in-one-event-calendar/public/themes-ai1ec/gamma/css/ai1ec_parsed_css.css?ver=2.5.37' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.chestnuthilllocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/social_widget.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='_tk-bootstrap-css'  href='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/resources/bootstrap/css/bootstrap.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='_tk-style-css'  href='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/style.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-dark-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/dark/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-default-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/default/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-standard-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/standard/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-thumbnails-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/thumbnails/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-font-awesome-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai/assets/css/font-awesome.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-googlemaps-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-googlemaps/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-directory-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-directory/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-paidlistings-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-paidlistings/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.1.5'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.1.5'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/resources/bootstrap/js/bootstrap.js?ver=5.1.5'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/js/bootstrap-wp.js?ver=5.1.5'></script>
<link rel='https://api.w.org/' href='https://www.chestnuthilllocal.com/wp-json/' />
<link rel='shortlink' href='https://www.chestnuthilllocal.com/?p=81964' />
<link rel="alternate" type="application/json+oembed" href="https://www.chestnuthilllocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chestnuthilllocal.com%2F2020%2F05%2F06%2Fletters-may-7-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.chestnuthilllocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chestnuthilllocal.com%2F2020%2F05%2F06%2Fletters-may-7-2%2F&#038;format=xml" />
		<script type="text/javascript">
			var _statcounter = _statcounter || [];
			_statcounter.push({"tags": {"author": "pete"}});
		</script>
		<meta name="twitter:partner" content="tfwp" />
<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Letters, May 7" /><meta name="twitter:site" content="@TheCHLocal" /><meta name="twitter:description" content="Unprecedented time caring for our community First, and most importantly, thank you for staying at home to help prevent the spread of COVID-19 in our community! It is critical that you continue to stay home, limit trips, and practice social distancing. Staying home is the single most beneficial action people can take for the health&hellip;" /><meta name="twitter:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2014/01/Letters.jpg" />







<!---->











<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700,800' rel='stylesheet' type='text/css'>















































<!--GOOGLE AD SERVER



<script type='text/javascript'>



var googletag = googletag || {};



googletag.cmd = googletag.cmd || [];



(function() {



var gads = document.createElement('script');



gads.async = true;



gads.type = 'text/javascript';



var useSSL = 'https:' == document.location.protocol;



gads.src = (useSSL ? 'https:' : 'http:') + 



'//www.googletagservices.com/tag/js/gpt.js';



var node = document.getElementsByTagName('script')[0];



node.parentNode.insertBefore(gads, node);



})();



</script>







<script type='text/javascript'>



googletag.cmd.push(function() {



googletag.defineSlot('/5267146/300x250_Sidebar', [300, 250], 'div-gpt-ad-1414505877457-0').addService(googletag.pubads());



googletag.pubads().enableSingleRequest();



googletag.enableServices();



});



</script>



-->



















<script async="true" src="https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/js/picturefill.js"></script>







<script>



jQuery(document).ready(function($){



	$("#main-menu > li > a").on("click",function(e){



		document.location = $(this).attr('href');



	});



});



</script>







<script>



  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){



  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),



  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)



  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');







  ga('create', 'UA-20971903-1', 'auto');



  ga('send', 'pageview');







</script>











</head>















<body data-rsssl=1 class="post-template-default single single-post postid-81964 single-format-standard group-blog">











	


    



    



  



    



    









<header id="masthead" class="site-header" role="banner">



	<div class="container" style="padding-left: 0px;">



		<div class="row">



			<div class="site-header-inner col-sm-12">



            



           



   



            



            <div class="row" style="margin-right: 0px;">



				<div class="col-sm-12  visible-sm visible-md  visible-lg">



                        <div id="sub-nav">



                        <ul id="menu-secondary-menu" class="menu"><li id="menu-item-39324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39324"><a href="http://nl.newsbank.com/sites/chlp/">Archives</a></li>
<li id="menu-item-39322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39322"><a href="https://www.chestnuthilllocal.com/links/">Links</a></li>
<li id="menu-item-41268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41268"><a href="https://www.chestnuthilllocal.com/about/">About</a></li>
<li id="menu-item-55921" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55921"><a href="https://www.chestnuthilllocal.com/contact/">Contact</a></li>
<li id="menu-item-39319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39319"><a href="https://www.chestnuthilllocal.com/welcome-chestnut-hill/">Welcome to Chestnut Hill</a></li>
</ul>


                   		 </div>



				</div>



			</div>



            



            



            <nav class="site-navigation">



	<div class="container">



		<div class="row">



			<div class="site-navigation-inner col-sm-12">



				<div class="navbar navbar-default">



					<div class="navbar-header">



					<!-- .navbar-toggle is used as the toggle for collapsed navbar content -->



					<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-responsive-collapse">



						<span class="sr-only">Toggle navigation</span>



					  <span class="icon-bar"></span>



					  <span class="icon-bar"></span>



					  <span class="icon-bar"></span>



					</button>







					<!-- Your site title as branding in the menu -->



					<!--<a class="navbar-brand" href="https://www.chestnuthilllocal.com/" title="Chestnut Hill Local Philadelphia PA" rel="home">Chestnut Hill Local Philadelphia PA</a>-->



				  </div>







				<!-- The WordPress Menu goes here -->



			<div class="collapse navbar-collapse navbar-responsive-collapse"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-81074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-81074"><a href="https://www.chestnuthilllocal.com/coronavirus/">Coronavirus Updates</a></li>
<li id="menu-item-63970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63970 dropdown"><a href="https://www.chestnuthilllocal.com/category/news/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">News <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-64007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64007"><a href="https://www.chestnuthilllocal.com/category/crime-report/">Crime Report</a></li>
	<li id="menu-item-39301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39301"><a href="https://www.chestnuthilllocal.com/local-troublespots/">Local Troublespots</a></li>
</ul>
</li>
<li id="menu-item-63975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63975 dropdown"><a href="https://www.chestnuthilllocal.com/category/opinion/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Opinion <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-39306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39306 dropdown-submenu"><a href="#" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Columns</a>
	<ul>
		<li id="menu-item-64011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64011"><a href="https://www.chestnuthilllocal.com/category/enemies-of-reading/">Enemies of Reading</a></li>
		<li id="menu-item-64014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64014"><a href="https://www.chestnuthilllocal.com/category/from-the-sidelines/">From the Sidelines</a></li>
		<li id="menu-item-67261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67261"><a href="https://www.chestnuthilllocal.com/category/opinion/ask-the-doc/">Ask the Doc</a></li>
		<li id="menu-item-64078" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64078"><a href="https://www.chestnuthilllocal.com/category/letters/">Letters</a></li>
		<li id="menu-item-76675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76675"><a href="https://www.chestnuthilllocal.com/category/opinion/on-the-avenue/">On the Avenue</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-76461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76461"><a href="https://www.chestnuthilllocal.com/category/community/">Community</a></li>
<li id="menu-item-76458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76458"><a href="https://www.chestnuthilllocal.com/category/schools/">Schools</a></li>
<li id="menu-item-63973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63973"><a href="https://www.chestnuthilllocal.com/category/sports/">Sports</a></li>
<li id="menu-item-76459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-76459 dropdown"><a href="https://www.chestnuthilllocal.com/category/obituaries/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Obituaries <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-76687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76687"><a href="https://www.chestnuthilllocal.com/category/death-notices/">Death Notices</a></li>
	<li id="menu-item-77776" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77776"><a href="https://www.chestnuthilllocal.com/category/obituaries/in-memoriam/">In Memoriam</a></li>
</ul>
</li>
<li id="menu-item-63972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63972 dropdown"><a href="https://www.chestnuthilllocal.com/category/arts/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Arts <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-64009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64009"><a href="https://www.chestnuthilllocal.com/category/note-worthy/">Note Worthy</a></li>
	<li id="menu-item-64008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64008"><a href="https://www.chestnuthilllocal.com/category/curtain-call/">Curtain Call</a></li>
</ul>
</li>
<li id="menu-item-76805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-76805 dropdown"><a href="https://www.chestnuthilllocal.com/category/critical-mass/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Critical Mass <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-76677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76677"><a href="https://www.chestnuthilllocal.com/category/critical-mass/flix/">Flix</a></li>
	<li id="menu-item-76678" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76678"><a href="https://www.chestnuthilllocal.com/category/critical-mass/liner-notes/">Liner Notes</a></li>
	<li id="menu-item-76845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76845"><a href="https://www.chestnuthilllocal.com/category/critical-mass/worth-reading/">Worth Reading</a></li>
</ul>
</li>
<li id="menu-item-76691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76691"><a href="https://www.chestnuthilllocal.com/category/homes-home/">Homes &#038; Home</a></li>
<li id="menu-item-76676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76676"><a href="https://www.chestnuthilllocal.com/category/business/">Business</a></li>
<li id="menu-item-76460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76460"><a href="https://www.chestnuthilllocal.com/category/mt-airy/">Mt. Airy</a></li>
<li id="menu-item-81011" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-81011"><a href="/classifieds2015/">Classifieds</a></li>
<li id="menu-item-81012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81012"><a href="https://www.chestnuthilllocal.com/careers/">Careers</a></li>
<li id="menu-item-81015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81015"><a href="https://www.chestnuthilllocal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-81017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81017"><a href="https://www.chestnuthilllocal.com/advertising/">Advertising</a></li>
</ul></div>






				</div><!-- .navbar -->



			</div>



		</div>



	</div><!-- .container -->



</nav><!-- .site-navigation -->



























 <div class="row">



				<div class="col-xs-12 col-sm-12 col-md-10 col-lg-9" style="background-color: #fff;">

				


                        	<div class="site-branding"><a href="https://www.chestnuthilllocal.com"><img style="border: 0px solid #f0f; float: left;" sizes="(min-width: 40em) 80vw, 100vw"



        srcset="https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo400.png 600w, https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo500.png 960w, https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo700.png 1200w" alt="Logo"></a>
 
<a id='gfm-charity-donate-link' style='background-color:#03866d; color: white; border-radius: 4px; padding: 12px 24px; display: inline-block; text-decoration: none; vertical-align: middle; font-size: 16px; font-family: Open Sans,sans-serif; line-height: 24px' role='button' href='https://charity.gofundme.com/o/en/donate-widget/8415'>Donate now to CH Local</a> 
                                </a></div>



                       	<div class="col-sm-12  hidden-xs" ><div class="landscape zone">



<br />















<broadstreet-zone zone-id="68059"></broadstreet-zone>						



						



                        



                        </div></div>



                        



                        



                       























				</div>



                <div class="hidden-xs hidden-sm col-md-2 col-lg-3" style="background-color: #fff;" >



					<form role="search" method="get" class="search-form" action="https://www.chestnuthilllocal.com/">
	<label>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
<h3>Follow Us!</h3><div class="socialmedia-buttons smw_left"><a href="http://www.facebook.com/pages/Philadelphia-PA/The-Chestnut-Hill-Local/166212318997" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/facebook.png" 
				alt="Follow Us on Facebook" 
				title="Follow Us on Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://twitter.com/TheCHLocal" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/twitter.png" 
				alt="Follow Us on Twitter" 
				title="Follow Us on Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.youtube.com/ChestnutHillLocal" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/youtube.png" 
				alt="Follow Us on YouTube" 
				title="Follow Us on YouTube" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="feed://chestnuthilllocal.com/?feed=rss2" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/rss.png" 
				alt="Follow Us on RSS" 
				title="Follow Us on RSS" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div>


				</div>



			</div>



            



            



            



				







			</div>



		</div>



	</div><!-- .container -->



</header><!-- #masthead -->















<div class="main-content">



	<div class="container">



		<div class="row">



			<div id="content" class="main-content-inner col-sm-12 col-md-8">
	
		


<!--- DO THIS IF IT'S A DIRECTORY ENTRY --->
 

<article id="post-81964" class="post-81964 post type-post status-publish format-standard has-post-thumbnail hentry category-letters tag-letters">
	<header class="page-header">
		<h1 class="page-title">Letters, May 7</h1>

		<div class="entry-meta">
			<span class="posted-on">Posted on <a href="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/" title="9:35 am" rel="bookmark"><time class="entry-date published" datetime="2020-05-06T09:35:07-04:00">May 6, 2020</time></a>, updated on <a href="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/" title="9:35 am" rel="bookmark"><time class="updated" datetime="2020-05-06T09:35:08-04:00">May 6, 2020</time></a></span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.chestnuthilllocal.com/author/pete/" title="View all posts by Pete Mazzaccaro">Pete Mazzaccaro</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content" style="padding: 0px 80px;">
		
<h4><strong>Unprecedented time caring for our community </strong></h4>



<p>First, and most importantly, thank
you for staying at home to help prevent the spread of COVID-19 in our community!
It is critical that you continue to stay home, limit trips, and practice social
distancing. Staying home is the single most beneficial action people can take for
the health of our team members, your family, and of your neighbors.</p>



<p>Our nurses, physicians, and support
staff continue to battle this invisible and insidious foe and work in ways we couldn’t
have predicted three months ago. The community’s show of support with well
wishes and donations provides much needed bright spots along the way. Please
keep them coming. </p>



<p>We have a whole new appreciation
for isolation masks and personal protective equipment. Your handmade masks are
helping us, by protecting others. We’re distributing these cloth masks to our
patients, and those who live with them, when they leave the Hospital and return
to the community. Individuals who come for lab work or imaging studies also
receive cloth masks for their safety and the protection of our team by reducing
transmission of droplets that may contain the virus. When you wear a mask, it
lets everyone know that you care, and that you are committed to making a
difference!</p>



<p>Our staff’s commitment to teamwork,
dedication, and ongoing training has enabled us to meet this crisis head on. Our
nurses have stepped up to ensure that the safety of our patients is a top
priority. In addition to their skilled clinical care, they provide the
compassion that’s missing from loved ones who can’t visit. Our staff is using two-way
technology to connect patients with their families. We will continue to put our
patients first – each time, every day!</p>



<p>With the support of our sister
Hospitals in Tower Health we will remain strong and prepared as we continue to
wage this health care battle. Our staff, our neighbors, and local businesses
have risen to the call and together we will prevail. Thank you!</p>



<p><strong>Timothy Marks, MBA, MSN, RN, CEN, NEA-BC </strong><br><strong>Vice President and Chief Nursing Officer </strong><br><strong>Chestnut Hill Hospital-Tower Health</strong></p>



<p></p>



<h4>Thank heroes at 7 p.m. nightly</h4>



<p>For these days of continuing isolation and
social distancing, I have decided that it is finally safe to wear my New York
Yankees baseball cap. This I choose to do each evening at 7 p.m. in support of
fellow New Yorkers (my town of origin) who shout and clap each evening to
support all the medical personnel who are helping all people affected by the
global pandemic at great personal risk. Lately, I have wondered if James Joyce
had it right when, in A Painful Case (from &#8220;The Dubliners&#8221; written
almost a century ago) he said that “Every bond is a bond to sorrow.&#8221; With
that aphorism, he surely did not have pandemics in mind but, perhaps, keeping
our distance in social relations.</p>



<p>For those of us who are nearing our own
denouement (I am 92), it is an especially difficult time. Most of us would
prefer to interact and talk with neighbors, attend concerts of the Philadelphia
Orchestra, eat at the Tavern on the Hill, Cin Cin and Paris Bistro. We can only
look forward to those days!</p>



<p>In the meantime, put on your Phillies cap and
join me for a few minutes at 7 p.m. every night in front of your own homes and
give thanks to all the medical personnel in New York and Philadelphia, as well
as others providing essential services (e.g., trash collectors, mail
deliverers, food service workers) who risk their lives to help all of us in
this time of need.</p>



<p><strong>Alex Bedrosian</strong><br><strong>Chestnut Hill</strong></p>



<h4>Please wear those masks!</h4>



<p>I am a Mt. Airy resident and love living in this area. I am posing something to the Local that perhaps we can get an article in the paper related to all the people who are happily enjoying Valley Green/Wissahickon Trail and their daily inability to distance themselves on their walks/hikes. I have spent many a happy moment through the years in this beloved park and am a current member of FOW. However, we have not even moved out of the pandemic restrictions in this area, and so many people are moving freely without masks on. OK, perhaps they can&#8217;t get one on their 3-year-old, or they are sick of being inside like all of us, and when they do come out, they throw all caution to the wind, but we must be vigilant as this pandemic has cost a lot of lives.<br></p>



<p>Could your paper make the call to remind people that they should still be social distancing, and if they aren&#8217;t using a mask, please stay away from others? I myself know what Covid-19 is like, and it is truly a serious business. I urge our community to call on others to please be responsible. They could still affect others, and we should remain diligent until a vaccine is found. I am appealing to your newspaper to get the word out. I would hate to see people become infected, and the park would shut down. People need to know that this can happen. We have to move forward and think of others, our park and our community. I truly appreciate the platform and hope to &#8220;see&#8221; the <em>Local</em> for a long time to come!<br></p>



<p><strong>Maryellen Norek<br>Mt. Airy</strong></p>
			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="https://www.chestnuthilllocal.com/category/letters/" rel="category tag">Letters</a> and tagged <a href="https://www.chestnuthilllocal.com/tag/letters/" rel="tag">Letters</a>. Bookmark the <a href="https://www.chestnuthilllocal.com/2020/05/06/letters-may-7-2/" title="Permalink to Letters, May 7" rel="bookmark">permalink</a>.
			</footer><!-- .entry-meta -->
</article><!-- #post-## -->

			<nav role="navigation" id="nav-below" class="post-navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<ul class="pager">

		
			<li class="nav-previous previous"><a href="https://www.chestnuthilllocal.com/2020/05/05/philadelphia-covid-19-update-mayor-announces-new-mural-arts-messaging-program-initiatives-for-youth/" rel="prev"><span class="meta-nav">&larr;</span> Philadelphia COVID-19 update: Mayor announces new Mural Arts messaging program, initiatives for youth</a></li>			<li class="nav-next next"><a href="https://www.chestnuthilllocal.com/2020/05/06/big-shoes-to-fill/" rel="next">Big shoes to fill <span class="meta-nav">&rarr;</span></a></li>
		
		</ul>
	</nav><!-- #nav-below -->
	
		
<div id="disqus_thread"></div>

	

	</div><!-- close .main-content-inner -->
 

	<div class="sidebar col-sm-12 col-md-4">

				<div class="sidebar-padder">
<a id='gfm-charity-donate-link' style='background-color:#03866d; color: white; border-radius: 4px; padding: 24px 24px; display: inline-block; text-decoration: none; vertical-align: center; font-size: 22px; font-family: Open Sans,sans-serif; line-height: 24px' role='button' href='https://charity.gofundme.com/o/en/donate-widget/8415'>Donate now to CH Local</a>  
<br>
<br>
<broadstreet-zone zone-id="72689"></broadstreet-zone>
	<br>
             <broadstreet-zone zone-id="68258"></broadstreet-zone>
<br>

		<broadstreet-zone zone-id="68058"></broadstreet-zone>
			

			

  
		 
        </div>
             
        
       <br> 
        
    <div data-cswidget="8292" > </div>
                       <script type="text/javascript" async defer src="//portal.CitySpark.com/js/widget.min.js" > </script>


						<aside id="text-3" class="widget widget_text"><h3 class="widget-title">Twitter</h3>			<div class="textwidget">            <a class="twitter-timeline"  href="https://twitter.com/TheCHLocal" data-widget-id="576441092830277634">Tweets by @TheCHLocal</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</aside>            
            <script type="text/javascript" src="https://chestnuthilllocal.disqus.com/combination_widget.js?num_items=3&hide_mods=0&color=grey&default_tab=popular&excerpt_length=200"></script></script>


            

		</div><!-- close .sidebar-padder -->...









			</div><!-- close .*-inner (main-content or sidebar, depending if sidebar is used) -->

            

   





            

           

<div class="row">

				

			</div>


<div id="circularhub_module_18569"></div>
<script src="//api.circularhub.com/18569/45a79329f113bf6b/flyertown_module.js"></script>

&nbsp;

<broadstreet-zone zone-id="76892"></broadstreet-zone>









		</div><!-- close .row -->

	</div><!-- close .container -->

</div><!-- close .main-content -->



<footer id="colophon" class="site-footer" role="contentinfo">

	<div class="container">

		<div class="row">

			<div class="site-footer-inner col-sm-12">

            



            

            

				<div class="site-info">

					

                    Copyright 2020 - All rights reserved.<br/><br />

                    

                    

                    

                    

<strong></strong>


                    

                    

                    

                    

					

				</div><!-- close .site-info -->



			</div>

		</div>

	</div><!-- close .container -->

</footer><!-- close #colophon -->



<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','letters','letters-may-7-2','post']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["letters","letters-may-7-2","post"],"url":"letters-may-7-2"};</script><script data-cfasync='false'>if (broadstreet) broadstreet.watch({});</script>		<!-- Start of StatCounter Code -->
		<script>
			<!--
			var sc_project=6394412;
			var sc_security="7d425857";
			      var sc_invisible=1;
			var scJsHost = (("https:" == document.location.protocol) ?
				"https://secure." : "http://www.");
			//-->
					</script>
		
<script type="text/javascript"
				src="https://secure.statcounter.com/counter/counter.js"
				async></script>		<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/6394412/0/7d425857/1/" alt="web analytics" /></a></div></noscript>
		<!-- End of StatCounter Code -->
		
<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '56150303'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = true; 
</script>


<!--
TPC! Memory Usage (http://webjawns.com)
Memory Usage: 61767168Memory Peak Usage: 62025384WP Memory Limit: 216MPHP Memory Limit: 340MCheckpoints: 9-->

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"chestnuthilllocal"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"81964 https:\/\/www.chestnuthilllocal.com\/?p=81964","disqusShortname":"chestnuthilllocal","disqusTitle":"Letters, May 7","disqusUrl":"https:\/\/www.chestnuthilllocal.com\/2020\/05\/06\/letters-may-7-2\/","postId":"81964"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/comment-reply.min.js?ver=5.1.5'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.carousel.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.swipe.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.tile.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.video.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/dark/script.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/thumbnails/script.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/js/client.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/wp-embed.min.js?ver=5.1.5'></script>
        <script type="text/javascript">
            function AI_responsive_widget() {
                jQuery('object.StefanoAI-youtube-responsive').each(function () {
                    jQuery(this).parent('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    jQuery(this).children('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    var width = jQuery(this).parent().innerWidth();
                    var maxwidth = jQuery(this).css('max-width').replace(/px/, '');
                    var pl = parseInt(jQuery(this).parent().css('padding-left').replace(/px/, ''));
                    var pr = parseInt(jQuery(this).parent().css('padding-right').replace(/px/, ''));
                    width = width - pl - pr;
                    if (maxwidth < width) {
                        width = maxwidth;
                    }
                    jQuery(this).css('width', width + "px");
                    jQuery(this).css('height', width / (16 / 9) + "px");
                    jQuery(this).find('iframe').css('width', width + "px");
                    jQuery(this).find('iframe').css('height', width / (16 / 9) + "px");
                });
            }
            if (typeof jQuery !== 'undefined') {
                jQuery(document).ready(function () {
                    var tag = document.createElement('script');
                    tag.src = "https://www.youtube.com/iframe_api";
                    var firstScriptTag = document.getElementsByTagName('script')[0];
                    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
                    AI_responsive_widget();
                });
                jQuery(window).resize(function () {
                    AI_responsive_widget();
                });
            }
                </script>
        


</body>

</html>

