<!DOCTYPE html>



<html lang="en-US" prefix="og: http://ogp.me/ns#">



<head>



<meta charset="UTF-8">



<meta name="viewport" content="width=device-width, initial-scale=1.0">



<title>- Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’ - Chestnut Hill Local Philadelphia PA -</title>



<link rel="profile" href="https://gmpg.org/xfn/11">



<link rel="pingback" href="https://www.chestnuthilllocal.com/xmlrpc.php">



		<!-- <script src="https://www.paypalobjects.com/api/checkout.js" data-version-4></script> -->
		
<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="by Sue Ann Rybak Despite dark skies threatening rain last Wednesday night, people packed the Center on the Hill, 8855 Germantown Ave., on May 29, to see"/>
<link rel="canonical" href="https://www.chestnuthilllocal.com/2019/06/07/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute/" />
<link rel="publisher" href="https://plus.google.com/+Chestnuthilllocal/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’ - Chestnut Hill Local Philadelphia PA" />
<meta property="og:description" content="by Sue Ann Rybak Despite dark skies threatening rain last Wednesday night, people packed the Center on the Hill, 8855 Germantown Ave., on May 29, to see" />
<meta property="og:url" content="https://www.chestnuthilllocal.com/2019/06/07/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute/" />
<meta property="og:site_name" content="Chestnut Hill Local Philadelphia PA" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Chestnut-Hill-Local/166212318997" />
<meta property="article:tag" content="Community" />
<meta property="article:tag" content="Mt. Airy" />
<meta property="article:section" content="Community" />
<meta property="article:published_time" content="2019-06-07T15:16:01+00:00" />
<meta property="og:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg" />
<meta property="og:image:secure_url" content="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="by Sue Ann Rybak Despite dark skies threatening rain last Wednesday night, people packed the Center on the Hill, 8855 Germantown Ave., on May 29, to see" />
<meta name="twitter:title" content="Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’ - Chestnut Hill Local Philadelphia PA" />
<meta name="twitter:site" content="@TheCHLocal" />
<meta name="twitter:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg" />
<meta name="twitter:creator" content="@TheCHLocal" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//code.tinypass.com' />
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Feed" href="https://www.chestnuthilllocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Comments Feed" href="https://www.chestnuthilllocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Chestnut Hill Local Philadelphia PA &raquo; Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’ Comments Feed" href="https://www.chestnuthilllocal.com/2019/06/07/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.chestnuthilllocal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//www.chestnuthilllocal.com/wp-content/plugins/all-in-one-event-calendar/public/themes-ai1ec/gamma/css/ai1ec_parsed_css.css?ver=2.5.37' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.chestnuthilllocal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/social_widget.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='_tk-bootstrap-css'  href='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/resources/bootstrap/css/bootstrap.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='_tk-style-css'  href='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-dark-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/dark/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-default-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/default/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-standard-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/standard/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-thumbnails-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/thumbnails/style.css?ver=2.10.4' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-font-awesome-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai/assets/css/font-awesome.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-googlemaps-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-googlemaps/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-paidlistings-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-paidlistings/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-directory-css'  href='https://www.chestnuthilllocal.com/wp-content/plugins/sabai-directory/assets/css/main.min.css?ver=1.3.11' type='text/css' media='all' />
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://code.tinypass.com/tpl/d1/tpm.js?ver=5.1.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/resources/bootstrap/js/bootstrap.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/js/bootstrap-wp.js?ver=5.1.1'></script>
<link rel='https://api.w.org/' href='https://www.chestnuthilllocal.com/wp-json/' />
<link rel='shortlink' href='https://www.chestnuthilllocal.com/?p=75988' />
<link rel="alternate" type="application/json+oembed" href="https://www.chestnuthilllocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chestnuthilllocal.com%2F2019%2F06%2F07%2Fcelebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.chestnuthilllocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chestnuthilllocal.com%2F2019%2F06%2F07%2Fcelebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute%2F&#038;format=xml" />
		<script type="text/javascript">
			var _statcounter = _statcounter || [];
			_statcounter.push({"tags": {"author": "Sue Ann Rybak"}});
		</script>
		<meta name="twitter:partner" content="tfwp" />
<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’" /><meta name="twitter:site" content="@TheCHLocal" /><meta name="twitter:description" content="by Sue Ann Rybak Despite dark skies threatening rain last Wednesday night, people packed the Center on the Hill, 8855 Germantown Ave., on May 29, to see some of the beautiful pieces of artwork in the Philadelphia Corporation for Aging&#039;s 17th Annual Celebrate Arts and Aging Festival. Held during Older Americans Month, the festival highlights&hellip;" /><meta name="twitter:image" content="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg" />







<!---->











<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700,800' rel='stylesheet' type='text/css'>















































<!--GOOGLE AD SERVER



<script type='text/javascript'>



var googletag = googletag || {};



googletag.cmd = googletag.cmd || [];



(function() {



var gads = document.createElement('script');



gads.async = true;



gads.type = 'text/javascript';



var useSSL = 'https:' == document.location.protocol;



gads.src = (useSSL ? 'https:' : 'http:') + 



'//www.googletagservices.com/tag/js/gpt.js';



var node = document.getElementsByTagName('script')[0];



node.parentNode.insertBefore(gads, node);



})();



</script>







<script type='text/javascript'>



googletag.cmd.push(function() {



googletag.defineSlot('/5267146/300x250_Sidebar', [300, 250], 'div-gpt-ad-1414505877457-0').addService(googletag.pubads());



googletag.pubads().enableSingleRequest();



googletag.enableServices();



});



</script>



-->



















<script async="true" src="https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/js/picturefill.js"></script>







<script>



jQuery(document).ready(function($){



	$("#main-menu > li > a").on("click",function(e){



		document.location = $(this).attr('href');



	});



});



</script>







<script>



  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){



  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),



  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)



  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');







  ga('create', 'UA-20971903-1', 'auto');



  ga('send', 'pageview');







</script>











</head>















<body data-rsssl=1 class="post-template-default single single-post postid-75988 single-format-standard group-blog">











	


    



    



  



    



    









<header id="masthead" class="site-header" role="banner">



	<div class="container" style="padding-left: 0px;">



		<div class="row">



			<div class="site-header-inner col-sm-12">



            



           



   



            



            <div class="row" style="margin-right: 0px;">



				<div class="col-sm-12  visible-sm visible-md  visible-lg">



                        <div id="sub-nav">



                        <ul id="menu-secondary-menu" class="menu"><li id="menu-item-39324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39324"><a href="http://nl.newsbank.com/sites/chlp/">Archives</a></li>
<li id="menu-item-39322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39322"><a href="https://www.chestnuthilllocal.com/links/">Links</a></li>
<li id="menu-item-70373" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70373"><a href="https://www.chestnuthilllocal.com/careers/">Careers</a></li>
<li id="menu-item-46097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46097"><a href="/classifieds2015/">Classifieds</a></li>
<li id="menu-item-41268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41268"><a href="https://www.chestnuthilllocal.com/about/">About</a></li>
<li id="menu-item-55921" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55921"><a href="https://www.chestnuthilllocal.com/contact/">Contact</a></li>
<li id="menu-item-39321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39321"><a href="https://www.chestnuthilllocal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-39320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39320"><a href="https://www.chestnuthilllocal.com/advertising/">Advertising</a></li>
<li id="menu-item-39319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39319"><a href="https://www.chestnuthilllocal.com/welcome-chestnut-hill/">Welcome to Chestnut Hill</a></li>
</ul>


                   		 </div>



				</div>



			</div>



            



            



            <nav class="site-navigation">



	<div class="container">



		<div class="row">



			<div class="site-navigation-inner col-sm-12">



				<div class="navbar navbar-default">



					<div class="navbar-header">



					<!-- .navbar-toggle is used as the toggle for collapsed navbar content -->



					<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-responsive-collapse">



						<span class="sr-only">Toggle navigation</span>



					  <span class="icon-bar"></span>



					  <span class="icon-bar"></span>



					  <span class="icon-bar"></span>



					</button>







					<!-- Your site title as branding in the menu -->



					<!--<a class="navbar-brand" href="https://www.chestnuthilllocal.com/" title="Chestnut Hill Local Philadelphia PA" rel="home">Chestnut Hill Local Philadelphia PA</a>-->



				  </div>







				<!-- The WordPress Menu goes here -->



			<div class="collapse navbar-collapse navbar-responsive-collapse"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-63970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63970 dropdown"><a href="https://www.chestnuthilllocal.com/category/news/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">News <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-64007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64007"><a href="https://www.chestnuthilllocal.com/category/crime-report/">Crime Report</a></li>
	<li id="menu-item-39301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39301"><a href="https://www.chestnuthilllocal.com/local-troublespots/">Local Troublespots</a></li>
</ul>
</li>
<li id="menu-item-63971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63971 dropdown"><a href="https://www.chestnuthilllocal.com/category/local-life/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Local Life <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-63978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63978"><a href="https://www.chestnuthilllocal.com/category/pets/">Pets</a></li>
</ul>
</li>
<li id="menu-item-63972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63972 dropdown"><a href="https://www.chestnuthilllocal.com/category/arts/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Arts <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-64009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64009"><a href="https://www.chestnuthilllocal.com/category/note-worthy/">Note Worthy</a></li>
	<li id="menu-item-64008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64008"><a href="https://www.chestnuthilllocal.com/category/curtain-call/">Curtain Call</a></li>
</ul>
</li>
<li id="menu-item-63973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63973"><a href="https://www.chestnuthilllocal.com/category/sports/">Sports</a></li>
<li id="menu-item-63974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63974"><a href="https://www.chestnuthilllocal.com/category/schools/">Schools</a></li>
<li id="menu-item-63975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63975 dropdown"><a href="https://www.chestnuthilllocal.com/category/opinion/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Opinion <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-39306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39306 dropdown-submenu"><a href="#" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Columns</a>
	<ul>
		<li id="menu-item-64011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64011"><a href="https://www.chestnuthilllocal.com/category/enemies-of-reading/">Enemies of Reading</a></li>
		<li id="menu-item-64014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64014"><a href="https://www.chestnuthilllocal.com/category/from-the-sidelines/">From the Sidelines</a></li>
		<li id="menu-item-67261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67261"><a href="https://www.chestnuthilllocal.com/category/opinion/ask-the-doc/">Ask the Doc</a></li>
	</ul>
</li>
	<li id="menu-item-64078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64078"><a href="https://www.chestnuthilllocal.com/category/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-63976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-63976 dropdown"><a href="https://www.chestnuthilllocal.com/category/obituaries/" data-toggle="dropdown" data-target="#" class="dropdown-toggle">Obituaries <span class="caret"></span></a>
<ul class="dropdown-menu">
	<li id="menu-item-64084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64084"><a href="https://www.chestnuthilllocal.com/category/death-notices/">Death Notices</a></li>
</ul>
</li>
<li id="menu-item-64153" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-64153"><a href="https://www.chestnuthilllocal.com/category/mt-airy/">Mt. Airy</a></li>
</ul></div>






				</div><!-- .navbar -->



			</div>



		</div>



	</div><!-- .container -->



</nav><!-- .site-navigation -->



























 <div class="row">

<broadstreet-zone zone-id="68532"></broadstreet-zone>

				<div class="col-xs-12 col-sm-12 col-md-10 col-lg-9" style="background-color: #fff;">



                        	<div class="site-branding"><a href="https://www.chestnuthilllocal.com"><img style="border: 0px solid #f0f; float: left;" sizes="(min-width: 40em) 80vw, 100vw"



        srcset="https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo400.png 600w, https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo500.png 960w, https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/images/logo700.png 1200w" alt="Logo"></a>



                                </a></div>



                       	<div class="col-sm-12  hidden-xs" ><div class="landscape zone">



<br />















<broadstreet-zone zone-id="68059"></broadstreet-zone>						



						



                        



                        </div></div>



                        



                        



                       























				</div>



                <div class="hidden-xs hidden-sm col-md-2 col-lg-3" style="background-color: #fff;" >



					<form role="search" method="get" class="search-form" action="https://www.chestnuthilllocal.com/">
	<label>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
<h3>Follow Us!</h3><div class="socialmedia-buttons smw_left"><a href="http://www.facebook.com/pages/Philadelphia-PA/The-Chestnut-Hill-Local/166212318997" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/facebook.png" 
				alt="Follow Us on Facebook" 
				title="Follow Us on Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://twitter.com/TheCHLocal" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/twitter.png" 
				alt="Follow Us on Twitter" 
				title="Follow Us on Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="http://www.youtube.com/ChestnutHillLocal" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/youtube.png" 
				alt="Follow Us on YouTube" 
				title="Follow Us on YouTube" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="feed://chestnuthilllocal.com/?feed=rss2" rel="nofollow" target="_blank"><img width="32" height="32" src="https://www.chestnuthilllocal.com/wp-content/plugins/social-media-widget/images/default/32/rss.png" 
				alt="Follow Us on RSS" 
				title="Follow Us on RSS" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div>


				</div>



			</div>



            



            



            



				







			</div>



		</div>



	</div><!-- .container -->



</header><!-- #masthead -->















<div class="main-content">



	<div class="container">



		<div class="row">



			<div id="content" class="main-content-inner col-sm-12 col-md-8">
	
		


<!--- DO THIS IF IT'S A DIRECTORY ENTRY --->
 

<article id="post-75988" class="post-75988 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-mt-airy tag-community tag-mt-airy">
	<header class="page-header">
		<h1 class="page-title">Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’</h1>

		<div class="entry-meta">
			<span class="posted-on">Posted on <a href="https://www.chestnuthilllocal.com/2019/06/07/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute/" title="11:16 am" rel="bookmark"><time class="entry-date published" datetime="2019-06-07T11:16:01-04:00">June 7, 2019</time></a></span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://www.chestnuthilllocal.com/author/sue-ann-rybak/" title="View all posts by Sue Ann Rybak">Sue Ann Rybak</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content" style="padding: 0px 80px;">
		<div id="attachment_75922" style="width: 650px" class="wp-caption aligncenter"><a href="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg"><img aria-describedby="caption-attachment-75922" class="size-full wp-image-75922" src="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg" alt="" width="640" height="480" data-id="75922" srcset="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging.jpg 640w, https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-300x225.jpg 300w, https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-600x450.jpg 600w" sizes="(max-width: 640px) 100vw, 640px" /></a><p id="caption-attachment-75922" class="wp-caption-text">Debbie Stevens, 69, of Northeast Philadelphia, with her piece, “Best Senior Friend.” Stevens&#8217; artwork was just one of 49 pieces that were on display at Center on the Hill for Philadelphia Corporation for Aging&#8217;s 17th Annual Celebrate Arts and Aging Festival. (Photo courtesy of Debbie Stevens)</p></div>
<p><strong>by Sue Ann Rybak</strong></p>
<p>Despite dark skies threatening rain last Wednesday night, people packed the Center on the Hill, 8855 Germantown Ave., on May 29, to see some of the beautiful pieces of artwork in the Philadelphia Corporation for Aging&#8217;s 17th Annual Celebrate Arts and Aging Festival.</p>
<p>Held during Older Americans Month, the festival highlights art work by 162 artists that range in age from 55 to 102. Works are exhibited at three sites, Center on the Hill, City Hall, and West Philadelphia Senior Community Center, and include paintings, drawings, ceramics, jewelry, fabric art, mixed media and photography.</p>
<p>In a statement, Holly Lange, PCA president and CEO, said the purpose of festival was “to showcase the outstanding work of senior artists and encourage older people to experience the wealth of artistic possibilities” available in Philadelphia.</p>
<p>“Older adults continue to grow and develop as they age and have extraordinary talent and wisdom to contribute,” she said. “We also know that staying active and engaged is one of the keys to healthy aging, and the arts specifically have been shown to have a broad range of physical, mental and emotional benefits.”</p>
<p>Najja Orr, PCA&#8217;s chief strategy officer, welcomed attendees and said this year&#8217;s theme for Older Americans Month was “Connect, Create and Contribute.” Orr said he couldn&#8217;t think of a better way to celebrate than to see some of the beautiful pieces of art done by older adults in the center.</p>
<p>He said that even though Celebrate Arts and Aging only ran until the end of May, thanks to senior centers and other community centers that offer art classes and workshops every month, Older Americans can enjoy the arts year-round.</p>
<p>Joe Clayback, marketing director for Always Best Care Services, said a lot of the art work on display had to be encouraged. He said many people don&#8217;t have the opportunity to take an art class or express themselves through the arts, until they “retire or have a little less responsibility in their life.” Clayback urged businesses and other community members to continue to support art [and other enrichment] programs at senior centers.</p>
<p>Mt. Airy resident David Greene said he believed everyone should have “an art experience.” Greene, a retired Philadelphia school district art teacher, taught art at Jenks Academy of the Arts and Sciences after he retired when the art and music programs were gutted due to budget cuts.</p>
<div id="attachment_75921" style="width: 650px" class="wp-caption aligncenter"><a href="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-2.jpg"><img aria-describedby="caption-attachment-75921" class="size-full wp-image-75921" src="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-2.jpg" alt="" width="640" height="480" data-id="75921" srcset="https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-2.jpg 640w, https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-2-300x225.jpg 300w, https://www.chestnuthilllocal.com/wp-content/uploads/2019/06/WEB-Arts-Aging-2-600x450.jpg 600w" sizes="(max-width: 640px) 100vw, 640px" /></a><p id="caption-attachment-75921" class="wp-caption-text">Mt. Airy resident David Greene, 70, a retired Philadelphia school district art teacher, whose son attended J.S. Jenks Academy for the Arts and Sciences in Chestnut Hill, with his photo: “Chase Utley.” (Photo by Sue Ann Rybak)</p></div>
<p>“You don&#8217;t have to be a certain age to do art, you just have to be willing to do it,” he said. “Art is something that is drawn on from past experience.</p>
<p>“In the 35 years I taught art, I never told anybody that they did lousy work, because that is not the nature of art,” he said. “We want to encourage young people to do art and the same goes for older people. That is why this show is excellent, because it is for people 55 and older.</p>
<p>“You don&#8217;t just stop doing artwork. You continue. Nobody realizes that a 90-year-old person or a 100-year-old person can do artwork. Sure, we can, and we do. And this is one way of saying that older people have many talents.”</p>
<p>Greene added that you have to do art to make you happy. For decades, his father didn&#8217;t like his art work until a few years before he died. Greene said initially, he began to question himself. Until he realized, it wasn&#8217;t his art work. It was just his father&#8217;s perspective of his artwork. There was no good or bad.</p>
<p>“You don&#8217;t have to do your artwork to please your husband, your wife or your children,” he said. “People should do art to make themselves happy.”</p>
<p>Debbie Stevens, 69, of Northeast Philadelphia, agrees. Stevens, a former horticultural therapist, who describes herself as shy recently took her first sketching class at KlineLife in the northeast.</p>
<p>The title of her piece is “Best Senior Friend.” It&#8217;s a portrait of her friend Barry.</p>
<p>“It&#8217;s the first portrait I ever did,” she said. “To me, it looks a bit rough. It makes me happy that he really likes it. Everybody said, &#8216;it captures his emotion.&#8217;”</p>
<p>Stevens was actually traveling to Illinois for a wedding when the deadline for submitting the application and photograph to PCA was approaching. She recalled going to Walgreens and asking the associate to help her scan the portrait.</p>
<p>“I really wanted to do this,” she said. “I never had the opportunity to participate in an art show with other artists and other seniors. I feel I have come to a stage in my life where really it&#8217;s been a joy. I am so glad that I reached out to do this art class. It&#8217;s been so good for me emotionally. And I have gotten all this positive feedback about my work. I am so thankful.</p>
<p>Recently, Stevens hung the picture of the portrait in her apartment and said she felt “this wonderful sense of pride inside.”</p>
			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="https://www.chestnuthilllocal.com/category/community/" rel="category tag">Community</a>, <a href="https://www.chestnuthilllocal.com/category/mt-airy/" rel="category tag">Mt. Airy</a> and tagged <a href="https://www.chestnuthilllocal.com/tag/community/" rel="tag">Community</a>, <a href="https://www.chestnuthilllocal.com/tag/mt-airy/" rel="tag">Mt. Airy</a>. Bookmark the <a href="https://www.chestnuthilllocal.com/2019/06/07/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute/" title="Permalink to Celebrate Arts and Aging Festival helps seniors ‘Connect, Create and Contribute’" rel="bookmark">permalink</a>.
			</footer><!-- .entry-meta -->
</article><!-- #post-## -->

			<nav role="navigation" id="nav-below" class="post-navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<ul class="pager">

		
			<li class="nav-previous previous"><a href="https://www.chestnuthilllocal.com/2019/06/07/joan-countryman-pioneering-educator-to-get-historic-germantown-hall-of-fame-award/" rel="prev"><span class="meta-nav">&larr;</span> Joan Countryman, pioneering educator, to get Historic Germantown Hall of Fame Award</a></li>			<li class="nav-next next"><a href="https://www.chestnuthilllocal.com/2019/06/07/concert-at-omc-interrupted-by-theft-of-cash-cell-phones/" rel="next">Concert at OMC interrupted by theft of cash, cell phones <span class="meta-nav">&rarr;</span></a></li>
		
		</ul>
	</nav><!-- #nav-below -->
	
		
<div id="disqus_thread"></div>

	

	</div><!-- close .main-content-inner -->
 

	<div class="sidebar col-sm-12 col-md-4">

				<div class="sidebar-padder">
        
        

             <broadstreet-zone zone-id="68258"></broadstreet-zone>
<br>

		<broadstreet-zone zone-id="68058"></broadstreet-zone>
  
		 
        </div>
             
        
       <br> 
        
    <div data-cswidget="8292" > </div>
                       <script type="text/javascript" async defer src="//portal.CitySpark.com/js/widget.min.js" > </script>


						<aside id="text-3" class="widget widget_text"><h3 class="widget-title">Twitter</h3>			<div class="textwidget">            <a class="twitter-timeline"  href="https://twitter.com/TheCHLocal" data-widget-id="576441092830277634">Tweets by @TheCHLocal</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</aside>            
            <script type="text/javascript" src="https://chestnuthilllocal.disqus.com/combination_widget.js?num_items=3&hide_mods=0&color=grey&default_tab=popular&excerpt_length=200"></script></script>


            

		</div><!-- close .sidebar-padder -->...









			</div><!-- close .*-inner (main-content or sidebar, depending if sidebar is used) -->

            

   





            

           

<div class="row">

				

			</div>



<broadstreet-zone zone-id="68059"></broadstreet-zone>









		</div><!-- close .row -->

	</div><!-- close .container -->

</div><!-- close .main-content -->



<footer id="colophon" class="site-footer" role="contentinfo">

	<div class="container">

		<div class="row">

			<div class="site-footer-inner col-sm-12">

            



            

            

				<div class="site-info">

					

                    Copyright 2019 - All rights reserved.<br/><br />

                    

                    

                    

                    

<strong></strong>


                    

                    

                    

                    

					

				</div><!-- close .site-info -->



			</div>

		</div>

	</div><!-- close .container -->

</footer><!-- close #colophon -->



<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','community','mt-airy','celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute','post']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["community","mt-airy","celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute","post"],"url":"celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute"};</script><script data-cfasync='false'>if (broadstreet) broadstreet.watch({});</script>		<!-- Start of StatCounter Code -->
		<script>
			<!--
			var sc_project=6394412;
			var sc_security="7d425857";
			      var sc_invisible=1;
			var scJsHost = (("https:" == document.location.protocol) ?
				"https://secure." : "http://www.");
			//-->
					</script>
		
<script type="text/javascript"
				src="https://secure.statcounter.com/counter/counter.js"
				async></script>		<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/6394412/0/7d425857/1/" alt="web analytics" /></a></div></noscript>
		<!-- End of StatCounter Code -->
		
<script type="text/javascript">
    window._tpm = window._tpm || [];
    window._tpm['paywallID'] = '56150303'; 
    window._tpm['sandbox'] = false; 
    window._tpm['trackPageview'] = true; 
</script>


<!--
TPC! Memory Usage (http://webjawns.com)
Memory Usage: 59666296Memory Peak Usage: 59914224WP Memory Limit: 216MPHP Memory Limit: 340MCheckpoints: 9-->

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"chestnuthilllocal"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"75988 https:\/\/www.chestnuthilllocal.com\/?p=75988","disqusShortname":"chestnuthilllocal","disqusTitle":"Celebrate Arts and Aging Festival helps seniors \u2018Connect, Create and Contribute\u2019","disqusUrl":"https:\/\/www.chestnuthilllocal.com\/2019\/06\/07\/celebrate-arts-and-aging-festival-helps-seniors-connect-create-and-contribute\/","postId":"75988"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/themes/dailyedition/includes/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/comment-reply.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.carousel.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.swipe.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.tile.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.video.min.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/dark/script.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/templates/thumbnails/script.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-content/plugins/cyclone-slider-2/js/client.js?ver=2.10.4'></script>
<script type='text/javascript' src='https://www.chestnuthilllocal.com/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>



</body>

</html>

